X   Сообщение сайта
(Сообщение закроется через 3 секунды)



 

Здравствуйте, гость ( Вход | Регистрация )

Открыть тему
Тема закрыта
> Кто шарит в формулах Ecxel?, работы минут на 10
smnv
smnv
Topic Starter сообщение 26.8.2012, 16:29; Ответить: smnv
Сообщение #1


Участник
***

Группа: User
Сообщений: 100
Регистрация: 25.5.2011
Поблагодарили: 11 раз
Репутация:   4  


Кто шарит в екселе я уже голову сломал)) нужна помощь, оплачу.

Бюджет по договоренности
Создание формулы в Excel
Нужно сделать простенькую формулу, имеется много чисел к примеру:
1,35
3,45
5,25
6,27
8,29
12,14
рядом в ячейке идет проверка каждого числа если он меньше или равен двум то пишется 2, если он больше двух но меньше или равен пяти то пишется 5, если он больше пяти но меньше или равен десяти то пишется 10, если больше десяти то пишется 15

Я там пробовал, но что-то я запутался,
=ЕСЛИ(RC[-1]<=2;2)+ЕСЛИ(2<RC[-1]>=5;5)+ЕС ЛИ(RC[-1]>=5;10)

в аську 47099066ноль
0
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
fioru
fioru
сообщение 26.8.2012, 16:40; Ответить: fioru
Сообщение #2


Завсегдатай
*****

Группа: Active User
Сообщений: 508
Регистрация: 30.11.2010
Из: Смоленск
Поблагодарили: 172 раза
Репутация:   37  


Почему Вы пишите ПЛЮС?

Вот ваша формула:
=ЕСЛИ(A1<=2;2;ЕСЛИ(A1<=5;5;ЕСЛИ(A1<=10;10;15)))

Ну или...

=ЕСЛИ(RC[-1]<=2;2;ЕСЛИ(RC[-1]<=5;5;ЕСЛИ(RC[-1]<=10;10;15)))


Поблагодарили: (1)
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
Nemovalex
Nemovalex
сообщение 26.8.2012, 16:42; Ответить: Nemovalex
Сообщение #3


Бывалый
****

Группа: User
Сообщений: 480
Регистрация: 18.4.2012
Из: Москва
Поблагодарили: 120 раз
Репутация:   24  


=ЕСЛИ(A1<=2;2;ЕСЛИ(2<A1>=5;5;ЕСЛИ(A1>=5;10)))

не стоит благодарности!

ой простите, не заметил, что уже решили эту проблему!


--------------------


Поблагодарили: (1)
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
fioru
fioru
сообщение 26.8.2012, 16:44; Ответить: fioru
Сообщение #4


Завсегдатай
*****

Группа: Active User
Сообщений: 508
Регистрация: 30.11.2010
Из: Смоленск
Поблагодарили: 172 раза
Репутация:   37  


(Nemovalex @ 26.8.2012, 16:42) *
2<A1>=5

А Вы проверяли в таком действии формулу? А то у меня ошибку выдавала, точнее не срабатывало условие. Пусть даже по логике такое написание не нужно делать, ибо раньше про 2 уже шла речь, но на будущее интересно: так пишут в Excel?

Сообщение отредактировал fioru - 26.8.2012, 16:44
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
Nemovalex
Nemovalex
сообщение 26.8.2012, 16:51; Ответить: Nemovalex
Сообщение #5


Бывалый
****

Группа: User
Сообщений: 480
Регистрация: 18.4.2012
Из: Москва
Поблагодарили: 120 раз
Репутация:   24  


У меня все работает, не знаю, попробуйте, скажите!


--------------------
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
smnv
smnv
Topic Starter сообщение 26.8.2012, 16:59; Ответить: smnv
Сообщение #6


Участник
***

Группа: User
Сообщений: 100
Регистрация: 25.5.2011
Поблагодарили: 11 раз
Репутация:   4  


Спасибо) а то у меня уже что-то голова не соображала))
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
fioru
fioru
сообщение 26.8.2012, 17:00; Ответить: fioru
Сообщение #7


Завсегдатай
*****

Группа: Active User
Сообщений: 508
Регистрация: 30.11.2010
Из: Смоленск
Поблагодарили: 172 раза
Репутация:   37  


(Nemovalex @ 26.8.2012, 16:51) *
У меня все работает, не знаю, попробуйте, скажите!

У меня если так записывать будет либо 2 либо 15 на выходе... только правда я писал не "2<A1>=5", поскольку если её прочитать будет белиберда, а записывал "2<A1<=5

Сообщение отредактировал fioru - 26.8.2012, 17:00
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
Открыть тему
Тема закрыта
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0


Свернуть

> Похожие темы

  Тема Ответов Автор Просмотров Последний ответ
Открытая тема (нет новых ответов) 10 бесплатных сервисов Google для бизнеса, о которых мало кто слышал
17 jack 5333 Вчера, 13:26
автор: Catherine_Molli
Горячая тема (нет новых ответов) Тема имеет прикрепленные файлыКто и что читает?
Любимые и не только, книги.
251 Levels 31072 11.12.2017, 16:47
автор: Catherine_Molli
Открытая тема (нет новых ответов) Кто продвигает сайт в яндексе массовой закупкой ссылок?
13 aleggator 1820 8.12.2017, 4:19
автор: KvadroJ
Открытая тема (нет новых ответов) Facebook палит прокси. Кто как решает эту проблему?
24 Twickbot 3187 29.11.2017, 9:30
автор: Mikki
Открытая тема (нет новых ответов) Мутаген в 2017. Кто работает?
8 OldSpice 1383 12.11.2017, 1:47
автор: _fan_


 



RSS Текстовая версия Сейчас: 13.12.2017, 3:48
Дизайн