X   Сообщение сайта
(Сообщение закроется через 3 секунды)



 

Здравствуйте, гость ( Вход | Регистрация )

Открыть тему
Тема закрыта
> Стоит ли ставить Denver 3 C Php 5.3, или же остаться на php 5.2
zetx
zetx
Topic Starter сообщение 23.2.2010, 14:21; Ответить: zetx
Сообщение #1


Участник
***

Группа: Banned
Сообщений: 211
Регистрация: 9.8.2009
Из: Россия
Поблагодарили: 15 раз
Репутация:   8  


Слышал есть какая-то несовместимость в новой версии php 5.3. Стоит ли сейчас ставить на локалхост новую версию?
В чем именно там несовместимости?
0
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
micakult
micakult
сообщение 23.2.2010, 14:35; Ответить: micakult
Сообщение #2


клоновод
******

Группа: Banned
Сообщений: 1057
Регистрация: 28.5.2009
Поблагодарили: 483 раза
Репутация:   77  


(zetx @ 23.2.2010, 13:21) *
Слышал есть какая-то несовместимость

Все там нормально совмещается smile.gif. Работает без проблем.


--------------------
Я клон maximiliano83, anderson и bookjoy
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
webnet
webnet
сообщение 23.2.2010, 14:39; Ответить: webnet
Сообщение #3


Бывалый
****

Группа: User
Сообщений: 371
Регистрация: 18.12.2008
Из: Москва
Поблагодарили: 61 раз
Репутация:   18  


Скорей всего ТС про совместимось php скриптов с версией 5.3 . Так как в ней намудрили достаточно .
Не совместимость там с регулярками . Если в скриптах такие имеются , то придется переписывать .
Ничего сложного в этом не вижу .

Сообщение отредактировал webnet - 23.2.2010, 15:12


--------------------


Поблагодарили: (1)
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
zetx
zetx
Topic Starter сообщение 23.2.2010, 16:00; Ответить: zetx
Сообщение #4


Участник
***

Группа: Banned
Сообщений: 211
Регистрация: 9.8.2009
Из: Россия
Поблагодарили: 15 раз
Репутация:   8  


webnet, да. Это я и имел ввиду.

на новом php мой самописный движок не работает...выдает ошибку:
Fatal error: Non-static method db::__construct() cannot be called statically, assuming $this from incompatible context in Z:\home\bodykey.my\www\libs\model.php  on line 8

Cейчас буду разбираться в чем там дело
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
isleman
isleman
сообщение 24.2.2010, 10:42; Ответить: isleman
Сообщение #5


Бывалый
****

Группа: User
Сообщений: 408
Регистрация: 16.10.2009
Из: НН
Поблагодарили: 83 раза
Репутация:   16  


(zetx @ 23.2.2010, 13:21) *
Стоит ли сейчас ставить на локалхост новую версию?

смотря чем вы занимаетесь, если разработкой нового движка, то безусловно стоит, если созданием сайтов на уже существующих движках, то нужно смотреть их требования к версии PHP


--------------------
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
Silverspam
Silverspam
сообщение 24.2.2010, 10:48; Ответить: Silverspam
Сообщение #6


Злобный SEO Злодей
*******

Группа: Super Moderator
Сообщений: 7627
Регистрация: 14.11.2009
Из: C Урала
Поблагодарили: 8205 раз
Репутация:   502  


У меня на 5.3 отказалась адекватно работать сборка WP Uranix. Также отказался работат парсер один.
Поэтому скачал денвер с 5.2 и теперь все нормально.


--------------------
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
VRUB
VRUB
сообщение 2.3.2010, 19:07; Ответить: VRUB
Сообщение #7


Участник
***

Группа: User
Сообщений: 177
Регистрация: 2.3.2010
Из: Москва
Поблагодарили: 29 раз
Репутация:   4  


Все верно если вы разработчик ставте Php 5.3 если нет то ненужно, поставил Php 5.3 начал устанавливать Modx три дня угробил на конфликт библиотек

Замечание модератора:
Эта тема была закрыта автоматически ввиду отсутствия активности в ней на протяжении 100+ дней.
Если Вы считаете ее актуальной и хотите оставить сообщение, то воспользуйтесь кнопкой
или обратитесь к любому из модераторов.
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
Открыть тему
Тема закрыта
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0


Свернуть

> Похожие темы

  Тема Ответов Автор Просмотров Последний ответ
Открытая тема (нет новых ответов) Тема имеет прикрепленные файлыСтоит ли выкладывать рекламу в яндекс ?
22 hacher54 3594 Вчера, 9:01
автор: pavloffk1r
Открытая тема (нет новых ответов) Нужна верстка со знанием php
4 Nemo 377 22.5.2018, 7:14
автор: Nemo
Открытая тема (нет новых ответов) Ищу php-программиста, работа с Yii2
0 eduarddis 314 19.5.2018, 15:58
автор: eduarddis
Горячая тема (нет новых ответов) Стоит ли раскручивать личную страничку ?
79 MakDonald 11542 19.5.2018, 12:46
автор: Emtec
Открытая тема (нет новых ответов) Веб-разработка (HTML5, CSS3, JavaScript, jQuery, Ajax, PHP)
20 qpPeW 5744 30.4.2018, 15:34
автор: koroluk1990


 



RSS Текстовая версия Сейчас: 25.5.2018, 9:41
Дизайн