X   Сообщение сайта
(Сообщение закроется через 3 секунды)



 

Здравствуйте, гость (

| Вход | Регистрация )

2 страниц V   1 2 >
Открыть тему
Тема закрыта
> Прошу помощи в устранении ошибок на DLE
Telnor
Telnor
Topic Starter сообщение 20.8.2018, 22:44; Ответить: Telnor
Сообщение #1


После переноса сайта http://mir-teatra.net/ на другой хостинг в шапке сайта вывалилась куча ошибок. Подскажите пожалуйста, как решить данную проблему? Спасибо!


--------------------
Накрутка ПФ Яндекса - от 200 рублей/запрос
***Естественные ссылки от 99 руб https://hidmark.ru/ ***
Сдам место в подписи, или обменяю на хостинг
0
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
qpPeW
qpPeW
сообщение 20.8.2018, 23:04; Ответить: qpPeW
Сообщение #2


Обратитесь к своему хостеру, Вы ему за это деньги платите...


--------------------
Веб-разработка (HTML5, CSS3, JavaScript, jQuery, Ajax, PHP) :: БЫСТРО :: КАЧЕСТВЕННО :: ДОСТУПНО
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
falken
falken
сообщение 20.8.2018, 23:13; Ответить: falken
Сообщение #3


Telnor, есть подозрение, что всему виной версия php.
в любом случае нужно писать хостеру )


--------------------
🗹 Быстрый и надежный хостинг от 135 рублей
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
gruz333
gruz333
сообщение 20.8.2018, 23:43; Ответить: gruz333
Сообщение #4


Telnor,
также думаю дело в версии PHP, если стоит ispmanager в нем можно изменить версию php


--------------------
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
Antonij
Antonij
сообщение 21.8.2018, 0:50; Ответить: Antonij
Сообщение #5


Ну как, хостер помог решить проблему? Если не помог, меняйте его нафиг!
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
kagtus
kagtus
сообщение 21.8.2018, 7:50; Ответить: kagtus
Сообщение #6


Цитата
Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in

ошибки из-за версии php - у вас старый dle (примерно до версии 9.6) и пхп 5.4 и выше
простым решением будет переключить в панели хостера на пхп 5.3
более правильным будет обновить dle до какой нибудь 9.8 (в идеале до последней версии, найти\скачать чистый думаю не проблема)
корявым решением будет исправление ошибок напрямую - статей на тему preg_replace(): The /e modifier очень много, но это фактически переписывание движка - то что разработчик dle уже сделал в более высокой версии чем у вас

P.S. хостер не отвечает за работу скриптов и движков клиентов, он лишь предоставляет серверные ресурсы и гарантирует их работу, исправление ошибок - задача клиента, не надо его левой неоплачиваемой работой грузить.

Сообщение отредактировал kagtus - 21.8.2018, 7:54


--------------------
ася 45два48499два
удалю вирусы, помогу с сайтом ->отзывы ТУТ и ТАМ


Поблагодарили: (1)
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
Sikorskaya
Sikorskaya
сообщение 21.8.2018, 12:35; Ответить: Sikorskaya
Сообщение #7


с версии 5.5 это preg_replace_callback

отключите в htaccess вывод ошибок
Цитата
php_value display_errors 0


Но лучше, как уже выше написали, понизьте версию php

Сообщение отредактировал Sikorskaya - 21.8.2018, 12:35
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
falken
falken
сообщение 21.8.2018, 16:52; Ответить: falken
Сообщение #8


Цитата(kagtus @ 21.8.2018, 6:50) *
исправление ошибок - задача клиента, не надо его левой неоплачиваемой работой грузить.

какой работой грузить?? подогнать версию php под cms? вот это нагрузка :D


--------------------
🗹 Быстрый и надежный хостинг от 135 рублей
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
mmkulikov
mmkulikov
сообщение 21.8.2018, 17:28; Ответить: mmkulikov
Сообщение #9


Цитата(falken @ 21.8.2018, 14:52) *
подогнать версию php под cms? вот это нагрузка

Это благая воля ТП ))
Какая проблема в панели (что там у ТС не угадаю, 90% что ISPManager) выбрать нужную версию. Тут как раз ТП легко подскажет КАК это сделать. А делать это за пользователя - это даже не верно. Мало-ли что считает "правильным" сам пользователь :D


--------------------
Сдается, обращаться скайп avdesk-it-kmm
VPS от 5€
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
falken
falken
сообщение 21.8.2018, 18:49; Ответить: falken
Сообщение #10


Цитата(mmkulikov @ 21.8.2018, 16:28) *
А делать это за пользователя - это даже не верно.

так в том и дело, что все упирается в поддержку :) в любой непонятной ситуации пишешь - либо подсказывают, либо решают сами, если сам саппорт конечно адекватный.


--------------------
🗹 Быстрый и надежный хостинг от 135 рублей
Вернуться в начало страницы
 
Ответить с цитированием данного сообщения
2 страниц V   1 2 >
Открыть тему
Тема закрыта
6 чел. читают эту тему (гостей: 6, скрытых пользователей: 0)
Пользователей: 0


Свернуть

> Похожие темы

  Тема Ответов Автор Просмотров Последний ответ
Открытая тема (нет новых ответов) Как установить код на dle от megaindex и других сайтов?
dle11.3
0 tsa 307 9.5.2021, 12:21
автор: tsa
Открытая тема (нет новых ответов) Прошу оценить сайт
Критика, советы и любые мнения приветствуются
16 KM_ 2151 1.5.2021, 17:31
автор: ViktoriaFE
Открытая тема (нет новых ответов) Тема имеет прикрепленные файлыПрошу оценки главной страницы
Меняю дизайн, не откажусб от советов
26 PostBrigada 4704 1.5.2021, 17:24
автор: ViktoriaFE
Открытая тема (нет новых ответов) Разработчики Google внесли изменение в определение ошибок Soft 404
3 VinogradOFF 1806 20.4.2021, 22:51
автор: Trumper
Открытая тема (нет новых ответов) Интеграция DLE с ЮКасса
Необходимо помочь настроить интеграцию
2 Concept 1182 27.3.2021, 15:18
автор: saintrick


 



RSS Текстовая версия Сейчас: 18.5.2021, 3:35
Дизайн